M1 Mac - Update tried, 97% done, did everything you suggested, tried 3 different cables from different brands - Now it's just frozen


Hey ya'll,


I have M1 Mac Mini (Also tried the same thing on my M1 Pro Macbook Pro), tried an update to the newest firmware. Didnt work from the first place, tried turning both my macs twice, didn't do anything further. (Tried every browsers - Chrome, Edge, Opera)

Now it says B0.7/M0.0/D1.2/READY and I'm just stuck with the amp that can't even produce sound because it can't do anything. Factory Reset with AMP - EXIT/STORE Method doesn't even try to respond. How do I go around it?

asked 02 Mar 2023 at 06:54 PM

Hong Jung
Similar problem with brand new Code 50. 147 updated and then frequent freezing of the controls. This one a one day old machine.

My solution, return the unit and look for something reliable For me, it points to flakey software. I'll not be buying Marshall again.
- Mike W 08 Mar 2023 at 08:11 PM
Answers: 3


I had the same problem with my Apple Mac air laptop.Aquired a cheap Lenovo windows machine and it updated immediately very fast.It was very disturbing to have a brand new Amp turn into a useless piece of junk.

answered 31 Mar 2023 at 12:54 AM

Keith Brough (2)


Update : I had to install Parallels and run Windows. It's been updated with no problemo. But I think compatibility on Mac is something serious that you guys should be working on.

answered 02 Mar 2023 at 10:49 PM

Hong Jung


Hong Jung, did you have a solution finally ? I'm in the exact same situation for a unit received today 

answered 30 Mar 2023 at 03:42 PM

Paul Zeitoun
Loading - please wait...
This site uses cookies to improve your experience. By continuing we assume that you're ok for us to store cookies on your device. You can change your cookie settings at any time, or delete cookies, by going to our cookie consent page.