Marshall Major II Bluetooth Headphones


Hi all,

On Christmas of 2016 I was bestowed upon the mightiest of gifts. And I have enjoyed every second from that first pairing to yesterday's low battery hum.

I've arrived home from work and went to charge the headphones. To my surprise in the morning when I went to unplug them they weren't showin' off the silver/white light indicating they've charged. I tried to turn them on and they wouldn't. I then went on to again plug them in and the red light indicator showed up that they're charging. I left for work and when I got back the light was off again.

I unplugged them, tried them on and still nada.

Since then I've been trying different USB cables which work just fine on other devices and I got nothing. When I put in the 3,5 jack it plays beautifully, but I kinda need the bluetooth part for work, so I was wondering if anyone ever got that problem.

I've googled and googled and the only conclucion I've come to is that I need to have them repaired from the shop that my wife bought them from for me.

Unfortunately that would mean at least a month without them and I'm trying to discover any other possibilities before turning to that one.


Cheers in advance if anyone reads this.

You're my only hope, guys and gals, I guess.


asked 18 Apr 2018 at 07:49 PM

Štěpán Verbík
Answers: 1


Hello Stephan,

We would recommend that you contact as this will take you directly through to Zound tecnhinal support for the headphones.


Kind Regards

Marshall Support

answered 19 Apr 2018 at 07:51 AM

Loading - please wait...