CODE 25 connects to PC but will not update firmware


My CODE 25 connects to my PC via both through MIDI in Chrome and through the Firmware Update Utility but it refuses to do anything but sit there while the gold loading circle just spins and spins. I've left it for upwards of 30 minutes. I'm unable to click on check for updates or anything. Tried rebooting a few times, tried turning blutooth off while doing it, etc. My amps current version according to both the amp and the app is v1.3. Any suggestion on what to try? Should I do some kind of factory reset to the amp and try again?  Any help or suggestions would be appreciated.

As a side note, I'm also unable to "download preset to amp" to test it out even though it's giving me the go ahead to do it on the preset site. I'm sure the issue is connected to being unable to update the firmware.


asked 21 Mar 2019 at 04:15 PM

Brett Ewaschuk
Answers: 1


Hi Brett,

If you are unable to download presets via My Marshall using USB, it would suggest there is something no right with the connection to your PC, please try the link below to see if this helps

Marshall Support

answered 22 Mar 2019 at 11:36 AM

Loading - please wait...