Marshall code 50 lockup when saving edit preset


Hi, I recently bought a code 50,, but about 6 times now, while holding the save button to quick save a preset, after  saving there is no sound from the amp, and I cannot change presets, or any other parameter. Turning the amp off ,then back on, and it starts working again. This is using the controls on the amp, not the gateway app. I checked the firmware about a week ago, and the program says I have the latest firmware.



asked 23 Aug 2016 at 03:20 AM

Richard Mcsweeney (1)
Hello, have you solved your issue? Sounds like a software bug to me.

Happened also to my brand new CODE 50, but just once.
What I did was reinstalling the latest firmware, and then doing a factory reset. Now the issue has not appeared.

I will post again to report how it goes.

- Dionysios Kalogerias 09 Sep 2016 at 11:15 PM
Hello, it happens to me too. But I remark that it arrives when the strings of my guitar are making a sound when I save the modification of the preset. But when I mute the strings (no sound is going into the amps), everything is OK. Check this point. It might be helpful. Philippe. - Philippe CABAU 30 Sep 2016 at 03:08 PM
since the last update, the problem is gone ! - Richard Mcsweeney 01 Dec 2016 at 01:31 PM
Answers: 4



This issue will be resolved once the update has been released. We thank you for your patience and apologise for the inconvinience caused at this time.

Team Marshall

answered 04 Oct 2016 at 11:12 AM



Hi Richard,

Might be worth try a factory reset on the amp, if this does not help, I would recommend you return it the dealer, to sort out a replacement or a repair.

Performing a factory reset will return CODE’s Presets back to when it was new.

 To perform a factory reset:

Power OFF the amplifier using the ON/OFF switch (#14 in this manual).

 Whilst holding down the AMP Section Switch, turn the power ON.

 The screen will display a notification that the amplifier is about to be returned to its factory settings.

 If you are sure that you want to perform a factory reset, press and hold the EXIT/STORE switch to confirm.

 If you do not want to restore the factory presets, pressing any other switch will cancel the

factory reset operation and boot the amplifier as normal


answered 23 Aug 2016 at 08:44 AM

So, is this a known issue or not?
I am kindly asking, in order to know what to do in case it happens again (it has happened once, but I reinstalled the firmware and all is good after that, so far...).

- Dionysios Kalogerias 09 Sep 2016 at 11:25 PM



I have the same issue, after I modify a preset and save it my amp doesn't give a sound anymore until I restart it.

I re-installed the latest (1.44) firmaware and did a factory reset too, but the issue is still there.

It's a CODE 50 (Serial: V02006750E)

Please help!

answered 01 Mar 2020 at 09:57 PM

Kornél Réfi
Hi Kornel,

I would recommend it being looked at by an engineer, it may need a new board.


Marshall Support
- Marshall 02 Mar 2020 at 09:56 AM



I just received a CODE 50 amp displaying this problem everytime i quicksave a preset via the amp controls. I have tried a factory reset with no luck.

Is this issue from 2016 still not resolved?! Do I really have to return it to a dealer after owning it for 3 days? What are the chances my replacement amp will have the same issue as I believe the dealer ordered this amp as brand new stock?

Not exactly a good first impression...

answered 28 Dec 2020 at 04:22 PM

Brad Turner
Hi Brad,

Thank you for your message, have you updated the firmware on your amp you may have an early model that the store had.

Marshall Support
- Marshall 03 Jan 2021 at 08:57 PM

Firmware was up to date but reinstalled it anyway. Still the same issue. Please advise. When were the early models replaced?
- Brad Turner 04 Jan 2021 at 06:32 PM
Hi Brad,

Thank you for your reply, could you please send us a video of this, to , and we can see what is happening, also if you can email over the serial number

Marshall Support
- Marshall 07 Jan 2021 at 08:58 AM
Hi, I sent the requested information to on 07/01 but am yet to receive any response. Please advise. - Brad Turner 14 Jan 2021 at 12:47 PM
Loading - please wait...