CODE worse with each firmware update
1

vote

I'd really like the ability to roll back firmware updates.  The tone of this amp has got worse with each firmware update I've installed.  I wish I would have left it at the default when I got it.

 

The first firmware update I installed ruined the DSL, and 50's British amps, and now this last update has ruined everything else.  All the presets I created sound completely different now.  What a waste!

 

I'm really beginning to regret buying a digital amp.  

edited 26 Oct 2017 at 03:47 PM

Sean Nixie (5)

asked 24 Oct 2017 at 07:39 PM

Sean Nixie (5)
Hi Code User 2

Thank you for your message, we have the team looking into this.

Kind Regards

Team Marshall
- Marshall 30 Oct 2017 at 10:25 AM
Do you have an update? I'd like to rollback to the previous version I had prior to updating to v1.41. Version 1.41 broke bluetooth connectivity, where bluetooth on the amp is no longer enabled automatically when I turn it on. I have to go through the manual pairing process (push Rev and Power) to turn on bluetooth, pair to my phone, and connect to Gateway each and everytime. Prior to the upgrade, I only had to do the pairing once (initial pairing), and every time I turned on the amp, it connected automatically without my intervention. - Tim S 14 Feb 2018 at 05:27 PM
I sent them the information they asked for and never heard anything after that. - Sean Nixie 14 Feb 2018 at 06:22 PM
Hi Tim,

We are working on a Bluetooth update for people that are having issues with connection.

Marshall Support
- Marshall 15 Feb 2018 at 09:08 AM
Answers: 1
0

votes

Hi,

If you have replaced the first 10 pre-sets on your amplifier when you installed the 1.41 firmware update don’t panic. To get the original presets back onto your amplifier simply re-download the pre-sets that will be available soon in the Presets section.

Marshall Support

answered 01 Nov 2017 at 02:08 PM

Marshall
I appreciate the reply but my issue isn't with pre-sets being replaced. It's with the "sound" of my created presets being different after updating the firmware. The presets I created sound much thinner and tinny than they did when I created them.

I could probably go back through all my presets and re-EQ them, but that really shouldn't have to be done, and what happens with the next update and it changes again.

It should be well documented what a firmware update alters and what the current version number is. The support page just links to some software. It should list all the firmware versions, the date they were released, and what the intended fixes are.
- Sean Nixie 01 Nov 2017 at 02:47 PM
We periodically update the CODE firmware to ensure we improve the amplifiers functionality and eliminate any bugs which may be present in the coding. For the most part these changes will not affect anything that you will notice in the amplifier and unless new pre-set sounds are downloaded then the functionality of your amplifier should not change. Changes to the firmware also DO NOT affect the DSP in the code amplifier so will not affect the tone of the amplifier in any way.
Regarding firmware updates, we are reviewing what information we include on each update to help you make a more informed choice.
We would however point out that many of the bug fixes that we undertake in firmware updates are not things that we would list as they are simple corrections in coding which do not affect the amplifiers performance or tone. Unless specifically stated a firmware update will NEVER affect the sound of the amplifier so as a general rule we would always recommend that users update to the latest firmware for their code amplifier to ensure optimum functionality.
- Marshall 01 Nov 2017 at 03:06 PM
I understand that it may not be intentional, but there are often unintended side effects from firmware updates. Since you stated "unless specifically stated" means that it is possible to affect the tone with a firmware update, which I believe is what has happened, unintentionally. - Sean Nixie 01 Nov 2017 at 03:38 PM
We now fully understand the issue you are experiencing we will now run an internal investigation to see if we can replicate the problem. Please can you send us the pre-set setting you feel the sound has changed on it may be easier to send them to servicedesk@marshallamps.com. We will be in touch with our results.






- Marshall 03 Nov 2017 at 09:48 AM
I can do that. How do you want the preset setting? Do you want me to email what the value of each option is set to? - Sean Nixie 03 Nov 2017 at 05:10 PM
Hi Sean,

If you can send screen shots that would be great.

Marshall Support
- Marshall 06 Nov 2017 at 09:54 AM
Loading - please wait...