Code 100H Firmware / Bluetooth




I recieved my Code 100H this week.


(FYI) I attempted the update with a MacBook Pro with USB-C, High Sierra 10.13.1, Chrome Browser. I was able to connect to the Code but the unit would not update. It was stalled on the progress bar on the unit at 0% and on the browser. 

(FYI) I attempted the update on a Windows machine and was successful using the update utility and with Chrome Browser. The Code unit shows updating to 1.4.1 but the boot screen shows 1.11?



The Code 100H will not connect to any Bluetooth device I have. Windows, Mac, iPhone, or iPad. It does not even show up as a device and never has even out of the box. I am convienced it does not work. Is there a master reset button combo for the unit? I am out of ideas concerning the Bluetooth. It seems like I am not the only one having issues with the Bluetooth. If this can't work consistently I am considering returning the unit. Even the simplest device can connect with Bluetooth and hold a connection. My Code 100H won't even show up as a device to connect to. Please advise. 


edited 12 Nov 2017 at 03:08 AM

Sean Whitaker

asked 11 Nov 2017 at 01:15 PM

Sean Whitaker
Answers: 4


Hi Sean,

Thank you for your message.

The 1.1 when you boot is not the firmware version its the amp version, if you hold down PFX, MOD and REV and turn the amp on you should see M1.41 which is your Firmware.

Regarding Bluetooth, please use the link below to help with Bluetooth connection.

Marshall Support

answered 13 Nov 2017 at 10:05 AM

Marshall Support,

I appreciate your comments. I did verify the firmware is updated to M1.41.

Regarding the Bluetooth connection. I have repededly followed the procedure to connect with multiple devices and have not had any success. The amp does not show up as a device to connect to . My primary device I am testing with is an iPhone7 with iOS 11.1.1 installed. I have tried the same paring proceedure with an iPad, MacBook Pro and Windows laptop with no success. The amp does not show up to connect to. Do you have any suggestions?
- Sean Whitaker 13 Nov 2017 at 12:26 PM


Team Marshall,

Update. The Bluetooth still does not work.

I deleted the Gateway app and rebooted the iPhone.

I deleted all Bluetooth devices connected to my iPhone.

I followed the procedures for connecting the amp via Bluetooth to my device.

I tried searching for Bluetooth in my device before initiating on the amp.

I have unplugged the amp and restarted my iPhone in an attempt to refresh settings  

Bluetooth on my amp does not work. Nothing will even see it as a device to connect to  

I need to know what Marshall can do before I am unable to return/replace your product. I am already losing 20% of the purchase to a restocking fee because I have registered the amp. I just want it to work as advertised. Please respond. 

answered 14 Nov 2017 at 12:31 AM

Sean Whitaker
Hi Sean,

Sorry you seem to be having this issue, when activating the Code's Bluetooth, do the Blue lights activate on the amp, are you connecting in Bluetooth setting first.

If you are doing all of the above it sounds like it could be an issue with the Bluetooth Module in the amp, and as the amp is under warranty we suggest you return it to the dealer for testing.

Marshall Support
- Marshall 14 Nov 2017 at 09:55 AM


So many people have problems with the bluetooth connection, including me.

I used a bluetooth scanner app, wich shows only the raw data of the bluetooth.
The Amp does not appear, every other bluetooth device i own gets listed in there.

The important thing in product design is TESTING. I think the bluetooth chipset
used in the amps is cheap chinaware. Sorry to say that, but thats how it is!

answered 26 Nov 2017 at 02:27 PM

Roman Kuhn
The latest update I have on my Bluetooth issue is I was directed to take the Code 100H in for local servicing/testing. I was told to allow two weeks to recieve an answer on the issue. I will update here later this week if I have results.

The Bluetooth module certainly does not work. Any other device that I scan for quickly pairs with any of my devices. Hopefully Marshall is replacing the module with a better unit.
- Sean Whitaker 26 Nov 2017 at 02:56 PM



I recieved my Code 100H back from the local Wizard Electronics. It turns out the Bluetooth module was not physically connected internally. The unit now works as it should out of the box. This could be a fix if others are experiencing no Bluetooth connection or an intermittent connection as the internal wiring my not be seated firmly. 

"And right now, it's time to..."

answered 10 Dec 2017 at 09:59 PM

Sean Whitaker
Same Problem in my Code 100 Head. The Bluetooth module was not connected to a 2 wire power cable.
After 120km drive and a repair which took 5 minutes i have a working amp now.
- Roman Kuhn 13 Dec 2017 at 07:20 AM
Loading - please wait...