Marshall DSL40CR high pitch noise
0

votes

Recently I heard a loud pop when going from standby to the 40 watt channel.  Amp still seems to work ok but since then there is a kind of minor but noticeable high pitch sound when on that 40 watt channel.  Cant hear it when on 20 watt.   You can hear it with nothing plugged into the amp and also when my guitar is plugged in.   The only noise noticeable before was just the normal kind of hiss sound that seems to be normal.   Also it doesnt get worse or better by turning the volume up or down.  Its just kind of there from the moment you click it on to the 40 watt.   Can hear it on clean channels also.   I'm 90 percent sure it seemed to have started right after that loud kind of pop when going from standy to the 40 watt.    Any thoughts or ideas on how to solve this?    Thanks for any input!!

edited 18 Apr 2022 at 12:48 AM

Casey Byrne

asked 17 Apr 2022 at 11:44 PM

Casey Byrne
In any event, providing that you have volume levels within reason and the guitar used works well on other amps without the squeal.... you could test a whole bunch a stuff looking for what's wrong however a brand new amp from the store ? be in perfect working order from the get go.. take it back. - fincher david 26 Apr 2022 at 05:39 PM
Answers: 1
0

votes

Hi Casey,

Thank you for the message, we would suggest having the amp looked at to be sure on what could be causing this, We would suggest contacting the dealer to help get this arranged for you.

Regards

Marshall Support

answered 19 Apr 2022 at 02:47 PM

Marshall
Loading - please wait...