Questions
Showing results 1 to 20 of 47
0

votes

1

answer

84

views

My CODE25 was repaired by Marshall in September after the amp itself kept crashing and the sound was cutting out. It has now been returned in an even worse condition.

On switching it on, the message 'Hold 'Store' to reset' appears on the screen. I press store and nothing happens. I am unable to access the amp presets.

After 10 minutes the mobile app then also freezes. I have contacted my Marshall dealer who sold me the amp and they have asked me to contact you for a resolution before I can send it back to them.

FYI: I have uninstalled and re-installed the mobile app without any resolution of the problem. The amp is is of no use and even a factory reset and firmware update has not solved the problem. I am gradually losing my faith in Marshall CODE products.

Do you have any solutions?

asked 04 Nov 2021 at 02:15 PM

Gerry McIntosh
0

votes

0

answers

38

views

Hiii

Last month (Sept. 2021) I was able to sync my Amp with the Gateway app. Unfortunately, This month/Today the app cannot detect/connect to my amp.  I already updated the firmware of my Code 50. Is there a way to sync it? because I already did what the tutorials said.

 

Thank you.

asked 30 Oct 2021 at 07:27 AM

Gabriel Sumat
0

votes

1

answer

156

views

I seem to be having the same issues that a lot of people have reported, where I cannot get the Marshall Gateway app to connect to my Code 25. I've only had the amp for about a week and I cannot get the app to see it. ? 

I can connect to the amp via Bluetooth using my phone (Pixel 3a, Android 11) and whilst connected, can use it as a BT speaker to play music from Spotify. However, nothing I do seems to get the app to connect to the amplifier. 

-I've updated the amp to the latest firmware using my laptop/web browser. 
-I've followed all the instructions in the Bluetooth Connectivity Troubleshooter to the letter (CODE - Gateway Bluetooth Connection Troubleshooting - my.marshall.com)

No matter what I do, or what order I install/uninstall/connect, the app will not see the amplifier. Everything works otherwise - I'm able to apply Patches from ? using a USB connection - and the amp sounds great. I'd just like to be able to control it from my phone.

edited 03 Oct 2021 at 01:11 AM

Harleigh Maguire

asked 16 Sep 2021 at 03:16 AM

Harleigh Maguire
0

votes

2

answers

219

views

I have a xiaomi redmi note 8 and also have a problem connecting the marshall gateway app to the amp code50.
I can only be connected as if I were listening to music, I even tried to connect it with an otg adapter, it works like that, but there are a lot of problems with braking the application? Please if it is possible to solve this problem.

 And if I tried all variants except one, and that is to uninstall every marshall application to amplify my Marshall Code 50 Firmware 1.4.4 recognize bluetooth connection from which I can control my installed Gateway 1.5.5 of course not just music to listen to But that I have complete control and whether maybe the problem is that the usb is included in my computer, whether to turn it off because I registered everything else. If anyone can answer all these questions I will be grateful.

asked 08 May 2021 at 09:33 AM

Vladimir kovacevic
0

votes

1

answer

277

views

I seem to be having the same issues that a lot of people have reported, where I cannot get the Marshall Gateway app to connect to my Code 25. I've only had the amp for about a week and I cannot get the app to see it.

I can connect to the amp via Bluetooth using my phone (Pixel 3a, Android 11) and whilst connected, can use it as a BT speaker to play music from Spotify. However, nothing I do seems to get the app to connect to the amplifier.

-I've updated the amp to the latest firmware using my laptop/web browser. 
-I've followed all the instructions in the Bluetooth Connectivity Troubleshooter to the letter (CODE - Gateway Bluetooth Connection Troubleshooting - my.marshall.com)

No matter what I do, or what order I install/uninstall/connect, the app will not see the amplifier. Everything works otherwise - I'm able to apply Patches from ? using a USB connection - and the amp sounds great. I'd just like to be able to control it from my phone.

asked 28 Mar 2021 at 10:54 AM

Andrew Jarvis
6

votes

1

answer

366

views

Here are a few things I would suggest as improvements to the Marshall Code series. I have a 25 so some things may be specific to that amp. I have stuck to things that could be improved only by software or firmware as these are improvements everyone can have simply by updating the firmware rather than modifying the amp itself.

1. Reduced power mode to switch between full power and lower power mode. This would fix the volume control issue everyone complains about.  Maybe this could be a global setting in the firmware ?

2. USB audio Volume level setting (e.g.  -3dB, 0dB, +3dB etc). This could also be a global setting in the firmware ?

2. Normalise the volumes of the models, some are way too hot (British class A power-amp), some are way too low (Natural pre-amp). I beleive this is the reason why some models have strange low frequency distortion (50s British, OD DSL).

3. Show the configuration of the Cab models, not everyone is a Marshall fanboy and I have no idea what cab a "1960X". even if it was displayed as "1960X (4x12)" I would at least know what the configuration of cab the model is.

4. Fix the spring and hall reverbs, they sound very cheap, like the "echo" you would get on a cheap karaoke machine, certainly nothing like a spring reverb.

5. For god's sake release an official desktop editor!!! with the option to save/restore/edit patches.

6. A sync button to sync the amp presets with your gateway. It you want to rearage the patches online in gateway, you have to manually save all the patches one at a time to the amp using the phone app. So if you add a new patch at position 0, you have to manually save all 100 patches one at a time in order to match your gateway sounds!

 7. Fix the tuner, it is pretty bad on both the amp and the app. It's slow to respond and not very accurate (at least thats what its like on mine). Ive no idea how well it works on the foot controller.

8. If possible add a Fuzz pedal model, even at the expense of removing another model (I wouldnt miss the pretty poor Acoustic simulator for instance).

These are just some suggestions that I feel would make the amp just a little bit better, but in general I'm having a lot of fun with this little amp, and love the sounds and features it has. It is way better sounding than some of the negative reviews online would suggest.

Maybe other people can suggest firmware updates too?

 

edited 22 Mar 2021 at 11:39 AM

Joliet Jake (61)

asked 21 Mar 2021 at 09:37 AM

Joliet Jake (61)
0

votes

1

answer

233

views

I have followed all the Forum and Support threads, re-installed current  Amp firmware, updated the Gateway App, restared everything several times... the iPhone does not see the Amp when blue light is flashing to 'pair'. Also not visible to ipad or other devices so I'm assuming it's a problem with the CODE system itself. I haven't even got as far as connecting the Gateway App!

Looking through the forum, this is clearly not an isolated event - looks like the Amp firmware is WAY behind current Bluetooth versions.

Any suggestions please? I am still within my return for credit timeline - should I send it back to the dealer?

asked 06 Feb 2021 at 12:12 PM

Tony Hulbert
0

votes

1

answer

616

views

Hi!!

Is there a printable list of the factory supplied Code 100 preset (Amp Firmware 1.44, DSP 1.1, BT 3.1, Gateway 1.5.5)?

Thanks in advance for your help.

George Betts

asked 27 Nov 2020 at 08:34 PM

George Betts
0

votes

0

answers

248

views

Yes, I've read the many questions of the same nature on the forum, and performed all the suggested actions. None of them have been successful.  I've seen many questions similar to mine, and only a few who have been able to make it work... and of those who did, their solutions didn't work for me.

When I connect my amp to my phone's bluetooth, it will pair for audio with no problems.  I can play audio through the amp.  When I open Gateway, there is no "red button" prompting me to connect.  When I tap on the CODE tab in the menu, it says "Not connected" and when I tap on the green "Scan for apps" button, nothing happens.

It will connect to my Samsung tablet with no issues.

Here are the steps I have tried:
Factory reset on the amp.
Unpair  and forget the amp in my phone's bluetooth settings.

Uninstall the app from my phone after clearing the cache and the data.

Update the firmware on the amp (the browser window said I was up to date but I installed the latest firmware anyway.)

What else can I do?  I don't want to return the amp because it sounds great, but not having the amp controls on my phone is a deal breaker.

 

 

asked 26 Sep 2020 at 06:59 AM

Jeremy Stroop
1

vote

4

answers

503

views

I have a Marshall Code 50 running MCU version 1.44 and Gateway (Android version 1.5.5) on a Samsung Galaxy S9+ running the latest OS. I can bluetooth pair to the amp and play music, but can not connect to the amp to change my presets from the library.  I have reloaded the latest firmware on the amp, deleted and reinstalled the Gateway app, paired and unpaired several times.  Nothing seems to work.  I even grabbed my old Galaxy S7 Edge phone and that Gateway app on it does the same thing.  Does my amp need to be serviced for Bluetooth connectivity?

asked 03 Aug 2020 at 12:12 PM

Kent Knudsen (1)
0

votes

1

answer

561

views

 

Hi,

 

I have found a weird thing that may or may not be known with iOS + Bluetooth and the Code 50.

The CODE 50 when playing backing tracks / using it as a Bluetooth speaker is very quiet (So the master is wacked up and the playing guitar is extremely loud). 

 

and the weirdest thing (which physically makes sense but still it shouldn't do it) is that the Amp is predominatly a Left speaker when playing music through bluetooth as my phone (iPhone 6S) thinks my amp is bluetooth headphones rather than speaker (as the headphone icon pops up on the top right). 

 

My amp is on the latest firmware update.

 

Is there any fix for this? There's nothing in the gateway app for audio balencing

 

asked 26 Jul 2020 at 09:49 PM

Ed Thwaites
0

votes

1

answer

420

views

I can't get the phone app and code 100 amp to connect. bluetooth does connect but the app will not show or allow to connect thus make the app unsuable. i have redownload app manty time. reconnected phone many times. amp is up to date firmware. i have had the app working fine and connected in the past.but now no matter how many redownloads, resets and starting fresh i can longer connect with the app to control it. i have been through every setting and all combinations on connecting updatig reseting and nothing seems to work. need help please. thank you.

asked 11 May 2020 at 03:31 PM

shawn isaac
2

votes

2

answers

674

views

I have the Code 25, and just installed the latest updates (1.44) to the firmware. However, I still cannont get the Gateway app to recognize the amp. I am connected via blue tooth as I can play music from my Android phone over the amp, but the controls from the app don't work at all. Again, when I search it does not find an amp. Help? 

asked 20 Feb 2020 at 05:08 PM

Tim Rogers (2)
4

votes

8

answers

1.1k

views

Hi I have a CODE 100H head/cab and a CODE 100 combo both with the latest firmware re-installed from Marshall and both have this issue, i.e. the amp very oftenn completely freezes when I save a preset.

Steps to reproduce:

- Modify any patch on the front panel

- Save

- 50% of the times the amp seems to freeze. The preset is saved but you can no longer change preset and there is no sound coming out.

The same happens if you modify a patch from the iOS app via bluetooth and then save it from there.

 

It's REALLY frustrating and I can't believe I didn't find anything on this forum under the "crash on save" keywords. Seeing it happens on both of my CODE units it much be a software bug, I don't think it has anything to do with my units.

Anyone else has seen this problem?

 

Thanks!

asked 23 Dec 2019 at 11:45 PM

Lele X (14)
0

votes

2

answers

819

views

I have a code 50 and am trying to update firmware. I have an iPhone X with the Chrome app installed (newest version). I am logged into my Marshall and the gateway app. The gateway app shows I am connected via Bluetooth, but on the my Marshall firmware download page it says I am not connected and my browser doesn’t support download. 

It’s very frustrating, Marshall or any support appreciated.

asked 19 Sep 2019 at 04:03 AM

Mar Fede-mac
0

votes

2

answers

747

views

Just bought my Code 50 tried to connect the Gateway App to either my iPhone 7 or iPad Air 2.

Did a firmware update to 1.44 , the amp is paired in Bluetooth but when in Gateway, it just says it is connecting but never does.

I have tried reinstalling the firmware, forgetting the edvice and re-pairing, removing all other BT devices etc. etc. but still it will not connect.

UPDATE: this was an iOS issue, not the amp. The latest update to iOS beta 13.1 resolved it. 

 

edited 07 Sep 2019 at 06:17 AM

Steven Clarke

asked 31 Aug 2019 at 04:56 PM

Steven Clarke
0

votes

1

answer

722

views

The iOS Gateway app was unable to connect to my CODE 50 even though my MacBook Pro is connected via bluetooth, so I did a factory reset and then tried to do a firmware update. The first part of the firmware update (1.44) appeared to install correctly. Next I saw a DSP update and tried to apply that update. In the middle of the DSP update, I received an error message to the effect that the update failed and I should power off & on my computer/device. I powered my Mac off & on, but the CODE 50 shows a progress indicator (about 20%) and says "DO NOT SWITCH OFF."

I tried to reinstall the firmware/DSP update, but this time the update process would not even begin. I suspect the  problem is the frozen progress indicator and whatever ongoing or frozen process is causing the "DO NOT SWITCH OFF" message.

Othe than ignoring the warning on the CODE 50 and powering it off & on, I don't see what else I can do. Is there a way to abort the ongoing or frozen process without turning the CODE off.

What should I do?

edited 28 Aug 2019 at 03:47 AM

Jim Marshall (12)

asked 28 Aug 2019 at 02:06 AM

Jim Marshall (12)
0

votes

0

answers

738

views

Hi, 

I have had my code 25 for about 6 months and for a while now, everytime I connect my phone and edit in the gateway app the preset freezes and I cannot change anything or change the preset. On the phone it says I am changing but there is no actual changes happening. On the little orange screen on the actual amp it stays on that preset even if I twist the knob to change preset but can still play and change volume.

TodayI was getting sick of it and looked up if there are updates for the amp and there are, which I then went and installed the latest firmware update. But now when I turn on the amp it shows that it's on and shows the preset but stays frozen and will not play sound at all. Is the amp done or can it be fixed?

asked 13 Aug 2019 at 08:03 AM

Krishan Talati
0

votes

2

answers

532

views

Hi There, 

I just notices this now. Im using a code 25. I have updated the firmware of the amp to 1.44. I also have updated the gateway 1.5.5. May phone connecting to the amp. But the gateway app is not connecting to the amp. Im using a galaxy note 9. 

 

Any help please. 

 

Thanks

 Jericho

 

asked 12 Jul 2019 at 01:20 AM

jericho zabala
0

votes

3

answers

731

views

I just bought a CODE 100 combo. Bluetooth audio is pairing just fine but the app never finds or connects to my CODE!

I tried everything, i even uninstalled the app rebooted the phone and started from scratch following your guide but still no luck.
Galaxy s9+ up to date CODE firmware 1.44 and gateway app 1.5.5

Fix this please

edited 12 Jul 2019 at 08:03 AM

Cris Lebrun

asked 11 Jul 2019 at 10:18 PM

Cris Lebrun
Showing results 1 to 20 of 47
Loading - please wait...