Questions
Showing results 1 to 12 of 12
0

votes

0

answers

97

views

Can I use Tung Sol EL34B tubes in my Origin 20H amplifier to replace the stock EL34 tubes ?

asked 08 Jul 2021 at 03:38 PM

RAYMOND N
0

votes

1

answer

666

views

Does the DI out of the Marshall Origin has cabsim or not?

Would like to know! 

Thanks

asked 16 Dec 2020 at 05:41 PM

Jeroen van Rijn
0

votes

1

answer

302

views

I know the origin 20 head has a dummy load for use without a cab and send to a daw through the di out. question is. Can I use the di out or fx send to a slave amp? Not a PA system but a 60 watt tube amp combo. 

edited 05 Sep 2020 at 04:57 PM

Labomba J

asked 05 Sep 2020 at 02:10 PM

Labomba J
0

votes

1

answer

453

views

Trying to clarify if what I have read applies to all Origin 20H amps.

I purchased a used Origin 20H.  The back of the head looks exactly like the picture in the slideshow on the Origin 20H webpage.  One 16 ohm out put and two separate 8 ohm outputs.  I have read a few different posts on various forums regarding the correct/incorrect labeling of these outputs on the Origin 20 amp heads.

So my question is...  Are the output jacks on my amp labeled correctly(one 16 ohm and two individual 8 ohm jacks) or should they have been labeled as I have been reading that when using both jacks 2 and 3 that only two 16 ohm speakers/cabinets should be used?

On the serial number tag there is code 05-18 which I assume means that the amp was manufactured in May 2018.

asked 20 Jul 2020 at 11:09 PM

Chris Hoppman
0

votes

1

answer

562

views

Hi,

If using headphones thru the line out do i disconnect the speaker to cab?

If running from line out to a recording interface eg behringer 404hd do i disconnect the speaker to cab?

If running a volume control in the effects loop can i plug headphones into the line out and listen thru the headphones? And do i disconnect cab?

If running from line out to a interface and using headphones out of the interface will this work. And do i disconnect cab?

Thanks Mark

 

 

asked 20 May 2020 at 08:01 AM

Mark Freshwater
0

votes

1

answer

778

views

Hi. Just verifying. Can I use The Behringer HA400 power headphone amplifier through the DI with the origin head without the cab attached or only into a mixing desk before removing the speaker ?
I’m just looking for best way to use headphones without the speaker attached .

thanks. 

P.s the origin amp is awesome. Love it. 

asked 19 Apr 2020 at 12:41 PM

Johnathan McLam (1)
0

votes

1

answer

1.3k

views

Hello,

The manual is very sparse about this. Could you please clearly outline the steps needed to safely operate Origin 20H with no speaker connected when using DI out for recording?

Is the DI out mono unbalanced or "stereo" balanced jack socket?

 

Regards 

Marek 

asked 30 Mar 2020 at 11:14 AM

Marek Siwczak (1)
0

votes

1

answer

554

views

Hello,

I recently purchased a Marshall Origin 20 Head and I am experiencing a rattling sound. Could this be the tubes or could it possibly be something else? Is there anything I can check on my own to narrow down the problem? 

Thanks,

 

D

asked 05 Mar 2020 at 12:33 AM

Dominic Lippillo
0

votes

1

answer

646

views

Hey

So I have an Origin 20H and was wondering if I could replace the EL34s with Kt77s and weather or not that would cause any problems. 

Ive heard they get more headroom and slightly better bass response 

Thank you 

asked 11 Feb 2020 at 04:35 PM

Matt Koeppicus
0

votes

1

answer

648

views

Hallo,

I just purchased my new Origin head 20H and I noted a discrepancy between the rear panel speaker TAGS and the electronic manual and photo available on Marshall website. In my amp there is the socket n.2 for a mono 8 ohm connection ans the socket n.3 is labeled with a dotted line to the n.2 for the connection of a pair of cabinet 16 ohm. while in the Marshall web site the sockets n.2 and n.3 are labeled with 8 ohm. Could you Clarify please? thanks.

edited 26 Aug 2019 at 10:12 AM

Roberto ACErob71

asked 26 Aug 2019 at 10:11 AM

Roberto ACErob71
0

votes

1

answer

790

views

I purchased an Origin 20H approximately 3 months ago.  Last night, I was playing it at healthy volume and it rapidly lost all sound.  Guitar plugged straight in to the input, nothing in the effects loop.  All tubes were still lit.  I tried different guitar chords, speaker cables, preamp tubes, plugging into different cabinets, different guitars.  All to no avail.  Any suggestions?  I have had no problems with the amp before last night.

asked 09 Jan 2019 at 02:40 PM

Craig Brown
0

votes

0

answers

390

views

I have an Origin 20H. When I rotate the tilt control clockwise, the amp produces a tone when an Archer Clean is connected to the input on the front panel and the Archer Clean is OFF.

Anyone else experiencing similar issues? 

asked 01 Dec 2018 at 12:50 AM

Richard Murphy
Showing results 1 to 12 of 12
Loading - please wait...