Questions
Showing results 1 to 4 of 4
0

votes

1

answer

228

views

I recently purchased a new SC20H. The production sticker date is 2019-34. When depressing the On/Off button for the loop there is a substantial  drop in volume. Also, there is a hum present when the loop is in use. Additionally, when engaging pedals in the loop a popping sound is present. This is not something I have experienced  with other amps and I did not expect in what is marketed as a high end Made in England Marshall. This amplifier was produced  some time ago as evidenced by the date sticker. Have these issues since been addressed? I do not want to submit a brand new amplifier for repair. I am still under the retailers return/exchange period. Would exchanging for a more recent  production SC20H resolve this issue?

asked 14 May 2021 at 01:55 AM

Quint Cunningham
0

votes

2

answers

278

views

Hello

Recently purchased this amp head only to find out that the effects loop does not works as advertised

I have tried an number of buffered and unbuffered pedals and the result is very frustrating

 When the loop switch is engaged with the amp in 5 watt mode there is an audible pop a noticeable hum comes from the amp/speakers and any effects connected pop loudly when engage/disengaged.

 When the loop switch is engaged with the amp in 20 watt mode (full power) there is an  audible pop a louder more annoying  hum coming from the amp/speakers and any effects connected pop loudly when engage/disengaged.

 I have also used just a quality effects pedal cable between the send/receive only to see if it’s just the pedals and the circuit still click and hums when engaged.

 This is totally unacceptable in any way shape of form and I would expect that with a brand such as Marshall and its long history of quality equipment that these type of issues would not exist as pre user testing would have sort them out!

This appears not to be the case as a number of online amp forums have pointed out that this is a know issue with this amp and no know solution or repair fix has been forthcoming from Marshall.

 Please issue a fix for this to be carried out by authorised service techs at your expense as this type of marketing and selling of equipment that is faulty and "not fit for purpose" is illegal under Australian consumer law and is most likley the case in other countries

 

I look forward to receiving a thoughtful and considered response to resolving this issue!

 

asked 11 May 2021 at 01:30 AM

Ross Ferro (1)
0

votes

1

answer

962

views

Hi, I have a queation about the Marshall Studio series of tube amps (Sorry it not CODE related)

i have all 3 amps in that serie, the SV20H Plexi, SC20H JCM800 and 2525c Jubilre

I would like to know more about the fx loop, is it line or intrument level ;

+4 (line/active current) fx loop

or

-10 (instrument/passive current) fx loop

it's not indicated anywhere in the user manual

I just want to know if I can use a regular stomp box delay and reverb in the loop or it's made to be used with rack effect.

Thanks in advance! 

 

 

asked 17 Oct 2019 at 12:53 PM

Stephane Ouellette
0

votes

1

answer

1.4k

views

Hi, I have a question about the Studio Series SV20H and SC20H DI OUT

The user manual say the DI OUT have emulation, but in both of your official product video on youtube (for SC20H and SV20H), Steve say the DI OUT is NOT emulated so it's perfect to use with our own Impulse response...

So who is right, the user manual or Marshall official product video?

https://www.youtube.com/watch?v=GvuQPnqMktc   at 2min43 he talk about the DI OUT and he say same for the video for the SC20H

Thanks in advance!

Stephane

 

 

asked 01 May 2019 at 05:29 AM

Stephane Ouellette
Showing results 1 to 4 of 4
Loading - please wait...