Questions
Showing results 1 to 5 of 5
0

votes

0

answers

53

views

Just bought a brand new Marshall SV20H 20/5 head. The item came from Europe and has the two pronged Euro mains lead cable.  Amp power rating is 230V.

I used a regular US grounded three pronged cable into my power regulator at 125 volts.

I then went and bought the little plastic 2-pronged Euro to US converter and plugged that into my power regulator with no change.

The power output from the amp is very weak and fizzy/thin. on the high setting?

Is my 125 US Power rating and cable at fault?

How do I use this amp here in the US with a 125 regulated power supply?

Please advise....

Texas Guitars

 

asked 06 Mar 2021 at 12:45 AM

John Davis
0

votes

1

answer

127

views

Just bought a SV212H with matching SV212 cab.

Even when the high treble volume is just above    Zero, there is a very noticeable hiss that is almost as loud as the guitar sound when playing clean.     When playing at home volumes and you let a chord ring, you can hear the hiss, surely this can’t be normal? The more you turn it up, the louder the hiss gets.

The normal channel 2 doesn’t have this hiss at all, even when really turned up. 

Is there a fault with the amp, or is this normal? 

It just really spoils playing moderate/low  volumes with  clean sound, I’ve never known a Marshall do this before. 

The official demo’s of the amp by Marshall don’t have the hiss when they pause playing or let a note decay. 

Help!

 

asked 07 Oct 2020 at 11:32 AM

Andy Traverse
0

votes

1

answer

442

views

Hi, just tried out my new SV20H head for the first time, running it through my fender 4 x 12 cab (8 ohms). Sounds awesome but I noticed a slight hum when the effects loop is activated. I was running a solid gold FX surf rider through the loop but it did the same with a Boss Space Echo as well. I also took the pedals out of the equation and just connected both send and return with a single jack cable and it still happened. It isn't a loud hum at all but I'm just checking if this is normal? My Origin 50 head that I have been using for the past year didn't make any hum at all with the same pedals!

asked 24 Dec 2019 at 08:32 AM

Paul Cashmore
0

votes

1

answer

617

views

Hi, I have a queation about the Marshall Studio series of tube amps (Sorry it not CODE related)

i have all 3 amps in that serie, the SV20H Plexi, SC20H JCM800 and 2525c Jubilre

I would like to know more about the fx loop, is it line or intrument level ;

+4 (line/active current) fx loop

or

-10 (instrument/passive current) fx loop

it's not indicated anywhere in the user manual

I just want to know if I can use a regular stomp box delay and reverb in the loop or it's made to be used with rack effect.

Thanks in advance! 

 

 

asked 17 Oct 2019 at 12:53 PM

Stephane Ouellette
0

votes

1

answer

1.1k

views

Hi, I have a question about the Studio Series SV20H and SC20H DI OUT

The user manual say the DI OUT have emulation, but in both of your official product video on youtube (for SC20H and SV20H), Steve say the DI OUT is NOT emulated so it's perfect to use with our own Impulse response...

So who is right, the user manual or Marshall official product video?

https://www.youtube.com/watch?v=GvuQPnqMktc   at 2min43 he talk about the DI OUT and he say same for the video for the SC20H

Thanks in advance!

Stephane

 

 

asked 01 May 2019 at 05:29 AM

Stephane Ouellette
Showing results 1 to 5 of 5
Loading - please wait...