Questions
Showing results 1 to 3 of 3
1

vote

1

answer

937

views

Hello,

I am a recent ower of a Marshall Origin 20, which I got in July. I've really enjoyed the amp until I plugged in last night and got out absolutely no sound out of it. I couldn't figure out why, as nothing as happened to it and it worked fine two days ago. I took it apart to do some trouble shooting and found that when I have all the knobs max'd and output on 20 watts, I can hear a whisper of my guitar signal (nicely saturated, presumably by the preamp tubes) through the speaker. This sound is affected by all of the knobs. However, if I plug my guitar directly into the return of the effects loop, and activate the effects loop I get no sound whatsoever; no guitar, no hum, nothing. Because of this, I'm sure my speaker is not the problem. These things led me to think it was a power amp section issue, so I went down and purchased a new set of matched EL34's, threw them in there, and nothing changed. I'd really like to know if there's anything I can do to fix this, because this amp is not even a year old and I should not be having these kinds of problems with completely normal bedroom use.

 

Thanks,

Alex

asked 12 Sep 2020 at 06:27 PM

Alex Peters (1)
0

votes

2

answers

1.2k

views

Hi,

guessing my asking this as a comment on another post got it lost.

can you explain how to use the DI please? Do I disconnect the speaker? Is the output line level? Does the powerstem have any effect?

new to having valves, like the amp but really would like this clarified.

ali

asked 20 Feb 2020 at 04:47 PM

Alistair James
0

votes

1

answer

1.8k

views

Hi Guys,

got an origin 20 combo, trying to use headphones on di out. What am I doing wrong? Got speaker working but no sound in headphones.

I take it first thing is unplug speaker??? Then what, do I need to change the power setting or something?

hanging off till I hear more.

ali

 

 

asked 19 Feb 2020 at 05:51 PM

Alistair James
Showing results 1 to 3 of 3
Loading - please wait...