Questions
Showing results 21 to 39 of 39
0

votes

1

answer

852

views

I've had my Code amp for a couple of weeks and managed to connect it to my iPhone which is running the latest ios 10.2.1.  I also got it to connect to a brand new Samsung Galaxy Tab A running Android 6.0.1.  The connection didn't always work and sometimes dropped out.  I've updated the Amp to the latest firmware to hopefully cure the connection issues and now my phone and tablet just can't detect the amp at all.  I've tried turning on and off, resetting everything, forgetting the device etc. etc. but it's like the amp just doesn't have Bluetooth.  As no device can see the amp then Gateway just isn't possible to use as it also can't detect a phone or tablet. My devices can see each other but it's like the Amp just doesn't have Bluetooth.  I've also tried searching for it with an Ipad but this also couldn't see the Amp ?  It looks like the Bluetooth has died on the Amp but thought I'd ask if anyone has any ideas of anything to try or otherwise I'll have to take it back to the dealer and either try another one or replace it with a Fender Mustang.  It's a good amp but seems to have to many glitches at the moment looking at the forums.  I'll give it one more go though if anyone has any suggestions to try.  Any ideas anyone ? Many thanks for reading.

Thanks for the responses.  I think it is a hardware issue though with the bluetooth just not working on the Amp.  It doesn't seem to matter what device I use the amplifier just isn't visible to anything ?

 

edited 11 Dec 2018 at 09:01 AM

Marshall

asked 10 Dec 2018 at 04:32 PM

jaison pandey
0

votes

1

answer

677

views

Hello, I have acquired the CODE 25, really an excellent amplifier, very versatile and very good presets. My problem and please I hope you help me to resorve it, is that even though I can connect via Bluetooth, I can listen to my tracks ....... the big problem is that when I want to use the FX or presets it appears that there is no amplifier connected ... (either from my android phone or my Ipad I ... I do not understand what the problem is.) Secondly, when I want to install the MARSHALL FIRMWARE UPDATE UTILITY, to enter presets or update the ampli, does not recognize the connection.I request guidance to be able to make full use of such a beautiful tool for my music.I use Widows 10 and G. Chrome.For your attention, thank you very much

asked 16 Oct 2018 at 05:55 AM

Luis Ernesto Espinoza Guerra
2

votes

5

answers

6.3k

views

Hi,

I recently purchased a Code 50 and have been trying to connect it to the gateway app on my Android phone. The phone connects to the amp successfully via bluetooth and I can stream the audio out to the amp directly using Spotify but when I go into the gateway app, it says "Not Connected". I tried the "Scan for Amps" button but it doesn't find anything. Any help is appreciated.

asked 02 Jul 2018 at 03:03 AM

Himanshu Chaturvedi (2)
1

vote

3

answers

1k

views

So I bought a Marshall CODE 50 a bit ago, and with nearly device I've tried - there seems to be a lot of issues with getting the gateway app to connect to the amplifier in general (most of the time it doesn't work - despite pairing just fine). 

I've tried this on the Samsung Galaxy S8, iPad 5th generation, iPhone 7+ - The connection issues seem to stem from the apps use of Btle on these devices. 

To experiment, I built an application that connects to the amplifier via bluetooth for Windows, and issues commands to the amplifier through the PC. This application uses a "classic" (SPP /RFCOMM) socket connection to send commands. The application works perfectly fine via this means - it can be seen running below: 

As an experiment - is there a way to force the mobile applications (if it isn't using a btclassic / rfcomm connection) to use a btclassic connection as opposed to btle? 

Thanks and all the best, 


Michael Mendelson

Principle Engineer, Pulse Interactive

Lead Software Engineer, Pirahna Bytes RED

edited 13 Apr 2018 at 11:01 PM

michael Mendelson (11)

asked 10 Apr 2018 at 04:53 AM

michael Mendelson (11)
0

votes

1

answer

1k

views

Hello. I just bought a code 50, and been trying to connect the Bluetooth but it simply doesn´t work. No Code50 is found in the list.
I have a Sony Xperia L, with the newest Android version (7+), but i can´t download the Marshall Gateway App from the Play Store, cause it says it´s not compatible with my Android version. 

I´ve read the forums, and more people seem to have the same problem. Please FIX so i can try using the full potential of my amp...

asked 09 Apr 2018 at 09:25 AM

Danilo Jose Duarte Neubern
0

votes

1

answer

1.1k

views

Hi, my Code 50 USB has stopped working, nothing wrong with the USB port because it still charges the phone - tried two cables, no luck.  So now I'm trying to figure out how to play songs through it via Bluetooth but *&^%%%%### no luck - how the hell do you do it? I've downloaded the Marshall Gateway app to my android but all i get is my phone icon and an arrow to the amp icon. DO I have to do something on the amp?

asked 07 Apr 2018 at 03:31 AM

Leone Britt
0

votes

4

answers

684

views

     I picked up a Code 50 last week so far I love it and the possibilities it offers.  Only issue I have had is when the Bluetooth is connected to my phone (Samsung Galaxy S7 Edge) if I get the phone too close to the amp I get a weird digital rattling sound coming from the amp.  I have not tried to see if same issue happens with my Android tablet though.  Has anyone one else had this problem or know the cause?

asked 12 Mar 2018 at 08:45 AM

charles turner
1

vote

2

answers

1k

views

hello,

Bluetooth connection is not very good in my opinion.

Bleutooth signal code 25 is ok, samsung s8 detects it alright.

But when i use the gateway android app it doesn't connect altough it shows in app as detected.

Is there a patch upcomming for the amp code series?

Greetings

 

asked 09 Feb 2018 at 05:04 AM

JB Hak (1)
0

votes

1

answer

687

views

I upgrade to Android 7.0

Bluetooth is ok (blue light fixed) but impossible to connect Gateway to my Code.

It worked with old Android version.

   What can I do?

asked 30 Jan 2018 at 09:13 PM

Etienne Grosjean
0

votes

2

answers

896

views

my code worked ok with my galaxy 5 but i got a new moto z running android 7.1.1 and it will connect to bluetooth but will not  connect in gateway. when i push scan for amps it never finds the code amp and yes i pushed the bluetooth buttons on the amp.  in the gateway app the in the bottom left corner the amp/phone icon is missing for switching from amp to phone presets. the screen has the blue preset shown but the library has them in yellow.  the worst part is that the display on the code amp is not working. it is barely readable. just yellow with the black barely visable. so without being able to program it using the display it doesn't work with my phone either.  i have owned a lot of marshalls and still have a bunch but i have never been so dissapointed as i am with this piece of crapp. can't use it live because of the dropouts when switching channels and yea i know about using the same amps and settings in all the presets but that is unaceptable. i have the footswitch and thats a disaster too. one little slip like accidently pushing two buttons at the same time or too fast or twice freezes the amp or reprograms it. yea really cool turning it off and back on in the middle of a song.  i tried using it live once and it was a disaster. never again. so i love the tone for recording but now i can't even do that because it wont connect bluetooth and the display is almost dead so i can't program it.

asked 15 Dec 2017 at 06:23 PM

ken nechvatal
0

votes

1

answer

1.1k

views

How to connect Marshal Code 25 via bluetooth to Android

Actualy my first try is on Samsung S5 Neo and they did not working 

I try My Asus tablet Android 7 and thy connected with no problem Marshall Gateway working fantasticly good

edited 25 Nov 2017 at 04:49 AM

Milutin Ninkovich

asked 25 Nov 2017 at 02:46 AM

Milutin Ninkovich
0

votes

4

answers

1k

views

Hi Support Team!

I am using a

Samsung Galaxy S7 Edge Device

with Android 7.0 

and Gateway App v 1.4.2

to a Marshall Code25 with the latest Firmware Version (as of 25 Sep 2017). The Firmware Update Utility says v 1.0.0.15 N in the bottom left corner.

I was able to use Gateway to control the Code25 until a while ago, I am not entirely certain if it was until the latest Android Update, but have a strong feeling it was until then.

Now I am able to pair the devices, connect via Bluetooth, Stream Audio over the Code, also able to FIND the Code in the Gateway App, but unfortunately I am not able to connect in the Gateway App. When I tap the Code in the Connect Menu, it says "Connecting..." but then nothing happens. It just will not connect.

I tried all your troubleshooting from the website, including Firmware Update, re-installing Gateway, unpairing, forgetting device, re-pairing etc.

I always end up in the "Connect..." mode and am not able to control the Code via Gateway.

I was very happy with amp and experience and really liked the remote function via mobile and Gateway app, even more now I am very disappointed that this bug persists already a few weeks with no App update or firmware update seeming to fix this. 

Please try to recreate the bug with the described configuration and please find a solution and release a bugfix/new software version.

Many thanks in advance and kind regards

Chris

asked 25 Sep 2017 at 07:45 PM

Christian Koch
0

votes

3

answers

1.2k

views

Well,  I've read through all the questions and answers I can.  My Android used to pair fine with my CODE 50.  Now, it will not connect.  I've reinstalled firmware, reinstalled the Gateway app, deleted and re-paired the amp.  Very frustrating.  It seems there are lots of issues with this.  I can hear the amp pair with the phone via bluetooth, but it will not connect with the Gateway.  "Connecting..." appears and doesn't go away.  I'm bummed.  This was a fun amp, but if the bluetooth doesn't work...  anyone got a fix?  Thanks.  Bill

asked 08 Aug 2017 at 02:30 AM

bill burke
0

votes

4

answers

1.2k

views

I've had my Code amp for a couple of weeks and managed to connect it to my iPhone which is running the latest ios 10.2.1.  I also got it to connect to a brand new Samsung Galaxy Tab A running Android 6.0.1.  The connection didn't always work and sometimes dropped out.  I've updated the Amp to the latest firmware to hopefully cure the connection issues and now my phone and tablet just can't detect the amp at all.  I've tried turning on and off, resetting everything, forgetting the device etc. etc. but it's like the amp just doesn't have Bluetooth.  As no device can see the amp then Gateway just isn't possible to use as it also can't detect a phone or tablet. My devices can see each other but it's like the Amp just doesn't have Bluetooth.  I've also tried searching for it with an Ipad but this also couldn't see the Amp ?  It looks like the Bluetooth has died on the Amp but thought I'd ask if anyone has any ideas of anything to try or otherwise I'll have to take it back to the dealer and either try another one or replace it with a Fender Mustang.  It's a good amp but seems to have to many glitches at the moment looking at the forums.  I'll give it one more go though if anyone has any suggestions to try.  Any ideas anyone ? Many thanks for reading.

 

Thanks for the responses.  I think it is a hardware issue though with the bluetooth just not working on the Amp.  It doesn't seem to matter what device I use the amplifier just isn't visible to anything ?

edited 27 Mar 2017 at 11:36 AM

David Keeley

asked 24 Mar 2017 at 10:40 PM

David Keeley
1

vote

0

answers

955

views

Hello!

 

!!! Ok, my bad. Figured it out. Had to put the amp in pairing more (Rev & Power) - then all is well. Sorry. !!!

(Feel dumb, bt I'll leave this in case someone else has similar issue.)

I had the amp successfully paird with a prior phone (Moto Droid as well - 2 yrs old?) Got a new phone - described above - Android v7. Not able to pair. Have uninstalled the Gateway app, (that got in the way last time, until the phone & amp were paired, then an install / connect went fine). This time... I get a cryptic, possibly IP6 number that looks like a device address. No code to enter, or anything to do. Phone says "Pairing..." waits maybe 10 seconds, then returns with "Pairing..." gone - no message, no nothing. Tried many many times. Cannot "forget the device" - phone doesn't offer a lot of choices: pair or disable Bluetooth is all...

 

Will the Code work with this phone? IS there a trick I hope I don't know? I sort of like the app - although I often use the knobs - it's just easier... So... I'm not going to hate you forever, but have to join the folks that are dissappointed with this. Amps are marvelous, but this software isn't measuring up I'm afraid.

 

Anyway, any help much appreciated!

Thanks

Steve

edited 22 Mar 2017 at 08:34 PM

Steve Noyes (3)

asked 22 Mar 2017 at 07:44 PM

Steve Noyes (3)
0

votes

1

answer

1k

views

Hello !

Like many of lucky owners of Marshall Code 50, I also have problem to pair Gateway app with Code. My phone (Ulefone Power with Android Mashmallow 6) recognize amp thru bluetooth and even play MP3 music, but can't work with Gateway. I wonder why ? I tried to rebooth code and phone several times, also install and uninstall app few times, but nothing helps. I upgraded firmware on my Code 50, still nothing. Can i expect fixed new version of gateway soon, and will it be tested on more smartphone brands ? 

greetings from Zagreb/Croatia

Tvrtko Grgic

tgrgic@hotmail.com

asked 01 Feb 2017 at 07:14 PM

Tvrtko Grgic
0

votes

2

answers

3.2k

views

So I just got my CODE50 two days ago and yesterday was the first day I had to play around on it, and that being at a live rehearsal of all places.  I didn't get to do much tweaking, but I noticed a problem with the EQ. If you have all buttons deactivated then the Bass Mid and Treble knobs do absolutely nothing, NOTHING...  I tried using the Natural preamp thinking that maybe the EQ knobs are strictly digital and an amp or preamp needed to be activated to enable the EQ to function.  When the Natural preamp was selected, however, the overall volume (master knob all the way up and the volume knob at 12 o'clock) was so low hardly anything could be heard.  Am I missing a menu option to set the volume or something?

 

Also, I've saw a lot of people having trouble getting the Marshall Gateway app to connect to their CODE amps, myself being one of these people unfortunately, but I haven't saw anyone come up with a definitive solution other than 1. Updating the Firmware 2. Turn the amp and phone off then restart both of them and try again. 3. Delete the amps Bluetooth profile from your phone and repeat step 2. 4. Call Marshall support.  I can get my Samsung Note 5 itself to connect to the amp (getting a weird message on my phone that says verify such and such number is the correct PIN for the Marshall amp but not having any further prompts on my phone or on the amp after tapping OK, but still connecting regardsless), but when I bring up the Marshall Gateway app and go into the menu to connect to the amp I can hit the scan button all day and it will NEVER find my CODE50.  What the huh?!!!  With all the other people I've saw on this forum having the same problem with the Bluetooth connectivity, you would think there would be a end-all-fix-all solution to such a massive problem. Has anyone heard anything or should I send this amp back for a refund while I still can?

asked 26 Jan 2017 at 02:42 PM

Joe Phinney
0

votes

7

answers

4.8k

views

Hi there Marshall team,

I was wondering if you could help me with a problem that I am having between my Code 25 amplifier and the Gateway app. I am able to pair my android device and the amp via Bluetooth just fine but once I am in the Gateway app it doesn't detect my amp at all, even when I press "scan for amp" it just says no amp detected. 

I think I should add that I have been able to connect it to my apple device without any problem at all.

It would be highly appreciated if you got back to me.

Thank you.

asked 28 Dec 2016 at 08:26 PM

Michael Huisamen (2)
0

votes

1

answer

1.3k

views

I purchased a Marshall Code 25 Watt amp today, and I am trying to connect it to my phone (Samsung s6 Edge+) via bluetooth, however, my phone will not discover it when scanning for available bluetooth devices. I have reset my phone and cycled the amp, and the problem persists. Are there any known issues with these devices or any workaround that I should look into?

asked 08 Sep 2016 at 01:41 AM

Trevor Moyle
Showing results 21 to 39 of 39
Loading - please wait...