Firmaware Update


How long the update process takes? Installation is already 100% but it seems it stuck and amp doesn't restart.

asked 21 Dec 2016 at 06:34 PM

Dhon Lalic
It seems the initial version also uninstalled... amp is not working... I used google chrome on Mac to update the firmware. - Dhon Lalic 21 Dec 2016 at 06:55 PM
The update takes less than a minute when it works. Just did it. Used a laptop and usb cable and plugged them both together and then ran the software. Got a error seeing the computer the first time and it looked like it was loading for like 20 minutes. The amp only said ready for update the whole time. I eventually closed the computer window and tried again. This time it zipped though and was done in prob less than a minute. the amp was showing download bars on it while it was updating. That was my experience so if it helps. :)
- Mark Ensign 23 Dec 2016 at 02:34 AM
Thanks! - Dhon Lalic 26 Dec 2016 at 02:12 AM
Answers: 1


Hi Dhon,

When you say your amp is not working, do you mean you are not getting any sound from it.


Team Marshall

answered 22 Dec 2016 at 09:11 AM

Same with Mark, I tried to re-start the update process and it installed correctly after 3rd try. Amp is now working but I am now worried with low ground current I am experiencing with metal panel and sometimes on the guitar strings. How can i solve this grounding problem? - Dhon Lalic 26 Dec 2016 at 02:10 AM
Loading - please wait...