Same issue/question that I see from so many people. Love the tones love the amp, the Gateway app is nearly useless as a control over Bluetooth.It will stay connected for about five minutes and then will drop. You can see it switch back-and-forth on the screen and then eventually even that icon will go away and you end up with no  connection through the app. Not a complete dealbreaker, but a major disappointment that a big selling feature of the amp does not work.

 Already updated the firmware, I sure hope Marshall finds and apply as a fix for this.  Their reputation for reliability was another big reason for the purchase. So as I said, very disappointing. 

 Does anyone know a fix, or has heard anything from Marshall that they're addressing this issue? 

asked 15 Jan 2017 at 02:15 PM

William Delmer
What's is your Gateway platform? I had nothing but issues on an android device, so I tried my iPhone and it was equally miserable until the recent release of Gateway. On the Android device I totally uninstalled the Gateway app, deleted the Bluetooth device association and reinstalled Gateway and had to pair to the amp again. Works great now, even actually syncs the profiles I have stored on the amp within about 20 seconds. I think the key was to break and re-pair the amp to the Andriod.

I haven't tried it on iPhone again because there is no need. Hope that helps.
- Michael McC 15 Jan 2017 at 03:04 PM
Answers: 3


Hello William,

Could you follow the steps below and tell me if it makes any difference at all?

close the app
delete it from your recently viewed app's
unpair with Bluetooth
turn the amp off

turn the amp back on
click on 'Rev and Power' on the amp and a blue light should start flashing
go back into your Bluetooth settings and pair with the amp
go into the app
on the left hand side of the app there should be a red tab that says connect
click on connect

answered 16 Jan 2017 at 09:20 AM



Hello, just bought a Code 50 and having trouble syncing with the Gateway Amp. Followed the instructions above and no sync. The Ipad syncs with the amp no problem but within the app there is no red button on the lower left. Under Menu the scan for amps button will blink brown if I touch it but only as long as I'm touching. Auto connect makes no difference whether its checked or not.

answered 25 Jan 2017 at 02:06 AM

brian hill
What generation iPad are you using Brian? - Marshall Amplification 25 Jan 2017 at 09:08 AM


unsure  its an older one . I can't find a version, the model number is MC981LL/A and the software is 9.3.5

answered 25 Jan 2017 at 11:17 PM

brian hill
Hi Brian, That's an iPad 2 and they are too old to work with Gateway. Saw it in this question - Fretbuzz Lightyear 07 Feb 2017 at 02:52 PM
Loading - please wait...