Amp + Gateway App


Hello, has anyone managed to solve the problem of connection via bluetooth gateway and amplifier? Simply DO NOT EXIST the bluetooth function on this product! 

asked 04 Apr 2017 at 01:02 PM

Juliano UL (1)
Mine worked for about the first month that I had the amp, a little glitchy but I was able to do what I wanted to do. Now my Samsung Galaxy 5 connects to the amps Bluetooth just fine for playing music or whatever, but the Gateway app will not connect to the amp anymore. - Dennis Bowen 05 Apr 2017 at 12:10 PM
Hi Dennis,
Have you tried unpairing the device and pairing again? ensuring that the Bluetooth is not connected to anything else?
- Marshall 02 Jun 2017 at 07:56 AM
Answers: 3


Hi Juliano,

What device are you currently trying to connect to the amp?

Team Marshall

answered 04 Apr 2017 at 03:25 PM

its got to be an update somewhere Mr Marshall. I have no issues whatsoever with amp, Bluetooth or app. I have the new app and everything I do on this site merrily makes it way to my phone (iPhone 5 - wifes hand me down LOL) and thus to my code25 with no issues at all. I have no issues with bluetooth connectivity at all - ever - turn on amp, activate app. connects almost immediately and doesn't loose connection . amp has not been updated from how I bought it - so stock at basic not updated status. that's go to be a hint surely. too many others who have updated the amp are having issues...just saying how it is with me :-)
- dave thomas 06 Apr 2017 at 09:31 AM
Thanks Dave for the feedback, we will pass that to our team.


Team Marshall
- Marshall 06 Apr 2017 at 10:40 AM


HI, Team Marshall , i'm using a Motorola Moto X 1st.

Thanks for the feedback!

answered 12 Apr 2017 at 01:16 PM

Juliano UL (1)



I updated my marshall code 25 with the firmware on the website today (using the windows installer), after that it worked fine on my 4.4.2 android, plus you have to press rev+power buttons in the amp to establish the connection. Hope it helps someone.

answered 17 Apr 2017 at 03:05 AM

Daniel Pino Gomes
Hello, my Moto X is in version 5.1 Android and kernel date March 2016.I believe to be some problem with the region because I'm in Brazil! But I already updated the firmware too and it did not solve! - Juliano UL 17 Apr 2017 at 05:19 PM
Juliano im from Brazil too. My gateway app cannot connect with my amp. Bluetooth connection is ok, but gateway not. Terrible. .. - Junior Bonora 29 Apr 2017 at 05:36 AM
Junior, e ae blz, cara tente conectar utilizando um iPhone, use o amp com iPhone e, depois conecte um Android.Por incrível que pareça funcionou assim. - Juliano UL 22 May 2017 at 02:23 PM
Loading - please wait...