Bluetooth connection problem with code 25
0

votes

I bought it yesterday and in the store it worked fine but then I turned it off and on again it will not connect I tried everything even deleted the app and it still not connect

"make sure code vo... turned on and in the range " 

please I need help 

 

asked 29 Apr 2017 at 08:51 AM

david asadov
What device are you trying to connect with code ? - Martin Blyth 29 Apr 2017 at 11:00 AM
I phone 6s
But the problem is that even with android it's making a problem and will not connect
- david asadov 01 May 2017 at 09:54 AM
I have the problem of not being able to connect via bluetooth since upgrading the firmware. Seems this is a common issue that needs sorting by Marshall. - Stephen Garside 17 Mar 2018 at 05:55 PM
Answers: 14
5

votes

Honestly, having to re-pair at each connection makes this whole process seem like it's from the past century.

answered 25 Sep 2017 at 04:20 PM

Gilles Gravier (15)
0

votes

Hello Frank,

Please be assured that our team are currently working on an update, as the issue is only affecting some users we need to ensure that the update doesn`t cause any further issues. 

 

Kind Regards

Marshall Support

 

answered 25 Oct 2018 at 08:30 AM

Marshall
0

votes

Hi Tim,

Yes your correct we get instant bluelight with connection after the update.

Marshall Support

answered 28 Feb 2018 at 08:58 AM

Marshall
1

vote

Hi Stuart,

No not every PCB Board is faulty, but in your case its worth getting it checked, we have lots of users with no issues with the new update, we have done lots of testings with the new update, with units working as they should.

Marshall Support

answered 28 Feb 2018 at 08:57 AM

Marshall
Why did the auto-connect work perfectly before the update, but not afterwards ? This implies that the PCB was fine before the update, but not afterwards. It also implies that the fault does lie with the update. It is extremely annoying that Marshall do not seem to be taking responsibility for this issue and correcting it ? Marshall need to start by recreating the problem themselves. This shouldn't be difficult, especially as so many people seem to be having the same problem !!! Marshall, please sort this out and quickly !!! - Stuart Harris 28 Feb 2018 at 10:01 AM
Same issue here, annoying. - Stephen Garside 17 Mar 2018 at 05:56 PM
1

vote

I have the same problem, I need to re-pair the amp with my device every time after I switch on the amp. This is extremely disappointing.

answered 02 Jan 2018 at 07:13 PM

Attila Kanto (1)
1

vote

Same problem. Seems as though the Bluetooth has to paired fresh every time you turn the amp on. Annoying. 

answered 17 Jan 2018 at 02:26 PM

Spiro Mandylor (1)
Same thing here. Have to start at the beginning each time. - Mickey Hunkin 25 Jan 2018 at 09:11 PM
1

vote

My bluetooth connection with the Code 25 and iPhone SE was working fine on the previous firmware version prior to upgrading it to v 1.41. I could turn on the amp, the blue light would come on immediately, and it would pair to my phone in a few seconds... every time.

Now after upgrading to v1.41, when I turn on the amp, the blue light does not come on, which indicates it doesn't turn on with bluetooth enabled anymore. The fact that I have to start the pairing process each time I turn on the amp by pushing Rev and Power, tells me the firmware update broke the Bluetooth function in that it no longer is enabled when you turn on the amp and the only way to enable it is to start the pairing process over each time. Unacceptable!

The issue is not with my phone. I also have an Android and get the same results. It is an issue with the Code amp. It no longer turns on with Bluetooth enabled... period.

If the answer from The Marshall Team is to go through the pairing process each time I turn on the amp, then this amp is not for me. Every other Bluetooth device I have turns on with Bluetooth enanbled and automatically pairs to my phone. And so should the Code amp.

Marshall Team, I have seven more days in my return window. If you don't have a better solution, a firmware update with a fix, or at least acknowledge the issue and confirm you are working on a fix, I will return this amp and choose another brand such as a Vox or Blackstar modeling amp. 

 

edited 14 Feb 2018 at 03:47 PM

Tim S (1)

answered 14 Feb 2018 at 03:45 PM

Tim S (1)
Hi Tim,

Sorry you seem to be having issues, the Firmware update 1.41 was for users to be able to upload the new presets, there was nothing with in update that would have been connected to the Bluetooth, we have fully tested the Code 1.41 update with a number of devices and amps with no issues.

Can you make sure your phones Bluetooth is switch on when switching the Code unit on.

There might be an issue with your Bluetooth PCB board and would recommend getting the unit looked at.

Marshall Support
- Marshall 15 Feb 2018 at 09:46 AM
I am having the same problem - Aaron Frank 26 Feb 2018 at 09:43 PM
We all seem to be having the same problem ie having to re-pair the Code amp every time we switch it on. Marshall Support, are you saying that every bluetooth PCB is faulty ? This is definitely an issue caused by the 1.41 update. My amp and the bluetooth connection were working perfectly before. I've tried a factory re-set, but that doesn't help either. When will there be another update and a fix ? - Stuart Harris 27 Feb 2018 at 07:52 PM
I took my Code 25 back to GC for an exchange. Waiting for the new one to come in and hoping it's not at 1.41. I will report back when I have it and try out the Bluetooth connection.

Team Marshall, I am in the IT field, and I can't tell you how many times I've seen code updates affect completely different parts of a program with no intent from the programmer in doing so.

In your testing of 1.41 with a number of devices and amps with no issues, are you saying your devices automatically (with no intervention) reconnect with the Code amp when turned on? You get an instant blue light without going through the pairing process? Or are you going through the pairing process each time you turn on the amp?
- Tim S 27 Feb 2018 at 09:36 PM
Same issue here, updated to 1.41 and I connect to the amp and played music through it but I can't connect or sync with the app. I have a Pixel XL with Oreo, 8.1. My son connected previously with his Moto Z and now can't connect either. - Jeff Schreffler 02 Mar 2018 at 01:47 PM
Marshall - PLEASE PLEASE PLEASE sort this problem out. We all appreciate that with IT issues bugs can occur. However, the measure of a good company is how quickly the problems are resolved. And when you do resolve the problem, please test it more thoroughly. - Stuart Harris 03 Mar 2018 at 11:32 AM
Me to in France. It all over the world. Please fix the update. Thx - Frederic Bataille 14 Mar 2018 at 05:05 PM
I have the new Code 25 from exchanging the defective one. It came out of the box at firmware v1.3. I have not upgraded the firmware. I have been using it for about a week now, and bluetooth has been working perfect. It automatically reconnects when I turn on the amp, and it no longer times out on me when I leave it on for long periods. So, bluetooth on the amp is enabled automatically every time I turn on the amp.

I will not upgrade the firmware to v1.41. With so many people experiencing loss of bluetooth function after upgrading to v1.41, it is either we all have a bad batch of PCBs (our amps were built from the same lot of defective PCBs) or it is the firmware upgrade that causes the issue. Since we all had perfectly functioning bluetooth prior to upgrading, seems to be an extremely unlikely coincidence that all of our PCBs go bad or show their defectiveness after the firmware upgrade.

Team Marshall, Is it we all got defective PCBs and it didn't exhibit the defective behavior until after the firmware upgrade, or is it just the firmware upgrade?
- Tim S 15 Mar 2018 at 08:52 PM
0

votes

I find mine is particular about the sequence of operations. Here's what works:

Turn code off. Turn on. Press REV+POWER until the blue light on the amp starts flashing.

On your phone/tablet, turn on bluetooth in the settings menu. Connect to Code Amp.

Open Gateway app. Open 'Menu' option, then CODE submenu. Connect.

I'm running everything on an ASUS Zenpad 7 with Android 5.0.  There have been connectivity problems reported with Android 6.0

Hope this helps!

answered 29 Apr 2017 at 10:05 PM

Peter McAteer (7)
there is no "Connect" choice in my Code sub menu, only scan for amps and auto connect or X auto connect. - Dan Saucier 10 May 2017 at 10:01 PM
Hi Dan

Please follow these steps, we have had no issue connecting a iPhone 7 with Gateway

the steps are -
close the app
delete it from your recently viewed app's
unpair with Bluetooth
turn the amp off

turn the amp back on
click on 'Rev and Power' on the amp and a blue light should start flashing
go back into your Bluetooth settings and pair with the amp
go into the app
on the left hand side of the app there should be a red tab that says connect
click on connect

Kind Regards

Team Marshall
- Marshall 11 May 2017 at 08:42 AM
Thanks Team Marshall, but do we really need to do that sequence every time we start this up?

I can't tell you how much time I have wasted on this issue. I have purchased over $3,000 worth of Marshall products and I am extremely disappointed in the performance of this product. I want to spend my time on my guitar chops, not on trying to figure out how to get the GD bluetooth to function properly. This should be a seamless transition rather than reinventing the wheel every time I start up up the CODE. At this point, I am seriously considering returning the CODE 50.

Ron
- Ron Martorella 14 May 2017 at 02:44 AM
Hi
Just bought 2 code 25's and have same problem with blue tooth connecting to iPhone6s. It seems that to make connection I need to re rest all settings each time . Bit of a disappointment for a 2017 system and for such an otherwise great amp. Is a firmware update due to cure problem ?
- malcolm dunbar 19 Aug 2017 at 07:10 AM
Team Marshall, Wrong answer. With firmware 1.41, Bluetooth is no longer enabled when turning on the amp. Why should we have to go through the manual pairing process each time to enable Bluetooth? That's unreasonable and unnecessary. After the initial pairing process, Bluetooth should be automatically enabled each time we turn on the amp. - Tim S 14 Feb 2018 at 03:53 PM
0

votes

I have the same problem. New update comming son? ??

answered 14 Mar 2018 at 08:10 PM

Frederic Bataille
Me too, very disappointing - Adrian Briggs 16 Apr 2018 at 10:15 PM
Me too,I bought code 25 yesterday,
and have a regret with.....
I have tried with iPhone xs MAX and iPAD pro. please do update,
Bluetooth and Volume troubles make me very sad...
- Kousuke Itou 08 Dec 2018 at 04:31 AM
0

votes

You gotta be kidding me. How can Marshall Support "supposedly" read all this, and not do a thing. I mean, its so many posts with so many people, saying the same problems. I just got my Code 100 and guess what, I got the same issue.

Although the only solution here to connect with bluetooth, "click" power + rev doesnt work. Not to mention that you dont "click" anything, its a damn switch that turns the power on on the amp. How to you click or "hold" that ? Sure, I can keep the REV button pressed after I pressed power on, but that wont change anything. No blue light flashing, nothing. How long do I need to press that REV button ?

@Marshall: Not having Bluetooth on automatically after the amp has been started, is the biggest bull i ever heard. I mean, do you really want to attract people with this sorta functionality, and then simply ignore if you screwed it up so it doesnt actually work ?

I am very disappointed. I thought, Marshall, you know, that name alone should be enough to know its good. But i guess i have to return my amp and get one that works, i dont know, from Boss or Fender. If thats what Marshall wants, loose people to other brands because they cant get their stuff working, well ok. Message received.

answered 18 May 2018 at 11:37 AM

Gerhard Verfürth
0

votes

Hi Marshall.

I have the same problem. I'm using Samsung Galaxy S8+.

When you fix the issue?

Best.

edited 05 Jun 2018 at 01:29 AM

Piero Ribeiro

answered 05 Jun 2018 at 01:28 AM

Piero Ribeiro
Hi Piero,

We are working on a Bluetooth Update to those having issues with connection.

Marshall Support
- Marshall 05 Jun 2018 at 07:51 AM
Thanks Marshall team - Piero Ribeiro 05 Jun 2018 at 05:10 PM
0

votes

Same problem with my code 25 and my samsung J7 2017. I need to re-pair the amp with my device every time.

Any news with this update ?

 

 

 

 

 

answered 26 Jun 2018 at 11:54 AM

Frank Delcourt
0

votes

I have to remove/forgot the Bluetooth setings every I Power on the CODE 100.

Another doubt please, if anybody could be help me, the CODE 100 isn’t there a line out ????

answered 18 Sep 2018 at 10:01 AM

Thiago Guilherme
0

votes

Hi Marshall,

 

how many years to have this firmware update to solve the problem  with bluetooth connection?

No firmware update since 10 oct 2017.

I think there will never be a firmware update.

Thank's Marshall. You are on top !!!!

answered 24 Oct 2018 at 03:24 PM

Frank Delcourt
Loading - please wait...