Unable to connect the IOS app to Acton II


I have installed the IOS app, and I have two Marshall speakers: the Acton II, and the Stanmore II.

The Stanmore had no issues, I suspect because it does not require a firmware update (yet).  The Acton II on the other hand, will not connect without a firmware update.  Taking that route, it leads to an indefinitel hang.  It starts and never moves past the 20% mark, and it stays that way indefinitely.

I've tried power-cycling the speaker.

I've tried factory-resetting it too.

I've also tried installing the app on my Mac (rather than the iPhone), with exactly the same results.


Anyone else come across this?


Updates from a Marshall support call to which I have responded:


Thanks for contacting the Marshall Support Team. 

Let's try a few steps to see if we can resolve this issue together.  

First: it is important to note that the Marshall Bluetooth app is NOT needed to pair the speaker to your phone. Please keep the app closed until you get to the very last section of the instructions below. 

(1) Perform a factory reset of the speaker:
- Press and HOLD the Source and Play/Pause button for 7-10 seconds​...DONE
- The SOURCE LED's will all flash quickly to confirm the reset was successful...DONE
- Remove the II Bluetooth from your audio device’s Bluetooth list before pairing again...DONE

(2) Connect the speaker to your phone via Bluetooth:
- make sure the Bluetooth menu on your phone (device) is CLOSED...DONE
- set the source to Bluetooth...DONE
- push and hold in the source button until the Bluetooth LED Light is flashing...DONE
- open the Bluetooth menu on your phone (or device), find & select the speaker...DONE

(3) Attempt to update the speaker again, complete these steps in this order:
- update the app to the latest version...DONE[UpToDate]
- make sure your phone and device are next to each other...DONE, and
- make sure that the speaker is powered on and connected to your phone via Bluetooth...DONE
- attempt to complete the update again...FAILED

Let us know if this helps. 


edited 05 Dec 2022 at 06:56 PM

Nima Talebi

asked 05 Dec 2022 at 02:01 AM

Nima Talebi
Same issue. Just purchased and can use the speaker but the Marshall Bluetooth app on iPhone tries to download the firmware but only shows a little bit has been downloaded and just stays there. I've tried resetting and re-installing app. No luck. - Jeremy Gayser 05 Dec 2022 at 02:27 AM
Thanks Jeremy. Please consider +1'ing this issue in case it helps Marshall prioritize bugfixes. - Nima Talebi 05 Dec 2022 at 06:57 PM
Answers: 1



Please contact support@marshallheadphones.com for help with Bluetooth speakers


Marshall Support

answered 05 Dec 2022 at 03:06 PM

Loading - please wait...
This site uses cookies to improve your experience. By continuing we assume that you're ok for us to store cookies on your device. You can change your cookie settings at any time, or delete cookies, by going to our cookie consent page.