Firmware update not working on Code 25



I've tried uploading the firmware on my Marshall Code 25 using the Chrome, Opera and Edge latest browser versions on my Macbook pro 12.3 (Monterey) using a midi usb cable.

When doing the update the amp connects and allows me to click update... it shows the progress to 100% but then gives the error below:

"An error occurred. The update process was not completed. Please try restarting your computer/device, and then try the update process again."

I must have tried this a 100 times with no success.

Now when i resart my amp to play some tunes the display says "CHK USB" and the amp wont work.

This is all very frustrating and i hope someone can assist.

edited 27 Mar 2022 at 01:33 PM

Karl Benn (1)

asked 27 Mar 2022 at 01:00 PM

Karl Benn (1)
Answers: 5


Hi Karl,

Please try the below to see if this helps ,

 MIDI troubleshooting tips:

  • Make sure that there aren’t other apps running that could be using the MIDI drivers, for example a DAW or MIDI monitor.
  • Make sure that there aren’t other browser tabs open that could be accessing the MIDI ports.
  • Try to switch the amp on in bootloader mode, by holding down the PreFX, Mod and Rev and then turning the amp power on.
  • Try a different USB cable.
  • If has access to a Windows PC, try downloading the firmware updater app from the MyMarshall website.


Marshall Support


answered 28 Mar 2022 at 03:15 PM

My issues are different. I have it connected and it says "Restarting in bootloader mode". This has been displayed for 30 minutes not. The amp (Code 100) says "Ready for Update". Nothing seems to be happening. When I try to exit it tells me not to exit while the upload is happening. I don't think anything is happening, but I'm afraid if I disconnect that I will break it. Please help. - Jason Crouch 09 Dec 2022 at 01:24 PM
Fixed... switched to a mac and no problem - Jason Crouch 09 Dec 2022 at 01:40 PM
I’m using a Mac and it still won’t update can someone please help me?

It said to download Google Chrone I did.

Now it says “Can’t connect too MIDI Device :-(

What can I do please someone?

And before anyone asks no I don’t have a PC I can use either.

Someone’s help would be VERY MUCH APPRECIATED thank you.
- Marc Ward 01 Jun 2023 at 01:56 PM


i also faced same issue, will try the trubleashooting tips.  dickssportinggoods feedback survey ?

edited 20 Apr 2022 at 03:10 PM

jose sally

answered 16 Apr 2022 at 12:12 PM

jose sally


Boujour, j'avais le même probleme. Je suis aussi sur mac et ça m'affiché le même message. j'ai essayé depuis un PC et ça à fonctionner. peut etre est ce une securité de apple ? Ou de norton ou autre ?

answered 10 Sep 2022 at 08:30 PM

Paul Heckel


I'm also having trouble using a MacBook Pro too update the firmware. It said use Google Chrome so I downloaded that and now I get a screen saying about "can't connect too MIDI disconnect and try again" 

I've used the boot loader too power up the code 25 with still the same conclusion. 

This is so frustrating and anyone help me please?


Thank you. 

answered 01 Jun 2023 at 01:53 PM

Marc Ward
Hi Marc,

You should note that Web MIDI is still a draft specification, and although we've found it to be pretty stable, there could be combinations of hardware and software which have problems.

If you still have problems using MIDI from this site, here are some things you can try:

Check that you have given permission for the My Marshall site to use MIDI devices in your browser. You will normally be prompted to do this the first time you use the site, but you can view and change the permissions later from your browser settings.

On Windows, only one application can use the underlying system MIDI driver at a time. Make sure that you're not running any other software that could be using the MIDI port, such as a Digital Audio Workstation or MIDI Mapper.

If MIDI initially works, but you then start to have problems, close all of your browser windows, and then check that there is not a hidden instance of the browser running in the background. On Windows, use the Task Manager to do this, and on a Mac you can use Activity Monitor.

If all else fails, try turning your computer off and back on again! Sometimes when things crash, they can take the MIDI drivers with them, and the only option is to do a reboot.

Marshall Support
- Marshall Amplification 02 Jun 2023 at 07:55 AM


Solution for CHK USB error: use Windows!

After a couple of hours of tries, either on Mac with Chrome or through Parallels with Edge/Windows 11, I could not make it work and my Code 25 was stuck with the CHK USB error. Luckily, I could borrow a Windows PC from a friend and that fixed the problem: I was able to repair the failed firmware upgrade. Good luck!

answered 06 Aug 2023 at 07:39 PM

Alex Hatt
Loading - please wait...