Can't get iPhone Gateway app to connect to Code 50


I bought a Code 50 today and I'm very pleased with it apart from one thing – I downloaded the Gateway app (1.2.7) for my iPhone 6 running the latest version of iOS (9.3.3) and no matter what I try, I can't get the app to connect to the amp. The amp is set up in bluetooth pairing mode, I've hit the "scan for amps button" on the app so many times my finger is about to fall off! I've restarted the phone numerous times, restarted the amp, you name it. It won't find it. Any advice appreciated!

asked 27 Jul 2016 at 11:06 PM

Matt Sefton (2)
I hope you got it fixed or figured it
Out haha I have a code 25 and had the same problem but I pressed the rev and power button at the same time and it came up immediately!
Try this hope it works
- Sam Bishop 19 Sep 2017 at 05:01 PM
Answers: 5


Hi Matt,

Please try the following

Unpair device, close the app, and turn off the amp.

Turn the Code back on Press REV and Power

Go to Bluetooth setting, search for devices, click on code name, and then pair

Go to Marshall Gateway app and click connect at the bottom left corner.

If you still have the same problem, Email us at

edited 04 Aug 2016 at 08:49 AM

Chris Robinson (338)

answered 03 Aug 2016 at 11:03 AM

Chris Robinson (338)
Thanks, that worked perfectly on my Samsung S8+. - Darryl Butt 15 Nov 2017 at 09:46 AM


I have the same problem.  I have tried two Android devices and one Kindle device, and none of them will pair.  I have tried power the device on and searching both before and after activating the amp bluetooth.  I think that either the amplifier bluetooth receiver/transmitter is not working properly, or the bluetooth software isn't allowing acquisition.

answered 15 Apr 2017 at 06:00 PM

David Laughon (2)


i have the same trubble , but no conect in left corner

answered 19 Dec 2016 at 11:45 PM

richard latten (1)
Hi Richard,

Could I ask what phone and model you have also what IOS/Android version you have.

Kind Regards

Team Marshall
- Lee Tomlin 20 Dec 2016 at 08:58 AM


I have the same problem, my cellphone connects to the bluetooth on the system (and the amp plays the music I put on the phone), but the app doesn't shows me any "connect" button on the bottom left corner, nor even detects the amp on the app...

I'm using a Xiaomi Redmi 3S with MIUI, android 6.0.1 MMB29M, and the app is up to date (v1.4.2)

Hope you answer soon Marshall Team.

answered 03 Jun 2017 at 08:23 PM

Roman Ochoa
Try opening the menu button, then click on Code and then scan for amps

Also I am not sure your device has Bluetooth LE which is needed to connect with Code
- Lee Tomlin 06 Jun 2017 at 11:05 AM


I'm having this problem too. Phone connected to Amp via Bluetooth but the gateway app doesn't show connect button. It worked previously. Also it works currently on a other phone but not on my primary device.Any fix yet?

edited 20 Jul 2017 at 10:21 AM

Sankalp Kumar

answered 20 Jul 2017 at 10:19 AM

Sankalp Kumar
Loading - please wait...