Cannot Update Firmware on Mac using Chrome


The bar just sits at 0%...what gives?

asked 19 Nov 2017 at 01:53 AM

Jason Estrella (4)
I’m having the same problem, anybody got anything? - Tommy Paraftsis 20 Nov 2017 at 05:51 AM
We need to group together. I’m having same problem. Please look what Marshall said to me, disgrace.
- ste cullen 25 Nov 2017 at 09:15 AM
Answers: 5



Thank you for your message, please try the link below to see if this helps with the update.

Marshall Support

answered 20 Nov 2017 at 09:17 AM

Tried that, still doesn’t work. Something is broken on your end, and it is defiantly Mac related, I ran windows through virtual machine and it updated fine - Tommy Paraftsis 20 Nov 2017 at 09:45 AM
Hi Tommy,

Thank you for the reply, we will pass this to the team.

Marshall Support
- Lee Tomlin 20 Nov 2017 at 09:47 AM
Tried this many times. Doesn't work. The update window shows "connected" but remains blank. Please fix this fast for Mac OSX users. - Prashant Bezboruah 26 Nov 2017 at 02:20 PM
Hello Prashant,
Thank you for your patience we are looking into this issue with the Mac software, we will keep you updated.
- JOANNA GREEN 27 Nov 2017 at 09:17 AM


Hi Tommy,

Please give this a try.

Switch their amp off.

Quit out of Chrome, if it is already running.

Start Chrome, and just open one tab for the My Marshall site.

Go to the Firmware Update page, and click on the button for 'Firmware Update in Browser'.

Switch on the amp in bootloader mode, by holding down the PreFX, Mod and Rev buttons, and then turning the power button to 'On'.

After a few seconds, the amp should show as connected..

Start the install, or reinstall, of the firmware.

Marshall Support

answered 20 Nov 2017 at 02:16 PM

This definitely didnt work for me. Spent hours trying. The dialog box opens, says its connected, my code 50 days it connected, then nothing happens. I left it for hours as I mentioned but no thing happens. There has to be something wrong on your end. - Jason Estrella 21 Nov 2017 at 05:30 AM
Yea same here, did that multiple times, the amp opens in boot mode but the browser window stays empty. Ive tried on multiple Macs with Chrome and Opera and get the same result, but if I try through Windows on my Mac using a virtual machine it works perfectly, so its defiantly a macOS support problem on your side - Tommy Paraftsis 22 Nov 2017 at 02:55 AM
I aslo want to add I can't send presets to the amp while while connected either - Tommy Paraftsis 22 Nov 2017 at 03:06 AM



We have our team looking into this.

Marshall Support

answered 22 Nov 2017 at 09:20 AM



MARSHALL what are you doing about this!!! You made out to me that no one is having problems! They are. What are you doing about it. And what are you doing about rubbish Bluetooth? Give your customer some proper answers. “We are looking into it” is a kop out. You have my details and the details of users having problems. Contact them and inform them what you are doing about. They have given you their hard earned cash. 

answered 25 Nov 2017 at 09:24 AM

ste cullen (5)


Hello Ste,

We understand your frustration regarding this issue we take all customers comments and problems seriously, please be ensured that we are looking into Mac firmware to try to address this issue. At present we cannot give you a timescale on the resolution but we will keep you updated. 


Kind Regards

Marshall Support. 

answered 27 Nov 2017 at 09:05 AM

Loading - please wait...
This site uses cookies to improve your experience. By continuing we assume that you're ok for us to store cookies on your device. You can change your cookie settings at any time, or delete cookies, by going to our cookie consent page.