Gateway app not detecting amp


Hi there Marshall team,

I was wondering if you could help me with a problem that I am having between my Code 25 amplifier and the Gateway app. I am able to pair my android device and the amp via Bluetooth just fine but once I am in the Gateway app it doesn't detect my amp at all, even when I press "scan for amp" it just says no amp detected. 

I think I should add that I have been able to connect it to my apple device without any problem at all.

It would be highly appreciated if you got back to me.

Thank you.

asked 28 Dec 2016 at 08:26 PM

Michael Huisamen (2)
Answers: 7


Hi Michael,

Thanks for the message, could I ask what Device/Model and IOS/Andriod version you have.


Team Marshall

answered 04 Jan 2017 at 01:22 PM

Could you follow the steps below and tell me if that works OK for you?
close the app
delete it from your recently viewed app's
unpair with Bluetooth
turn the amp off

turn the amp back on
click on 'Rev and Power' on the amp and a blue light should start flashing
go back into your Bluetooth settings and pair with the amp
go into the app
on the left hand side of the app there should be a red tab that says connect
click on connect
- Marshall 16 Jan 2017 at 09:13 AM
Tried it do many times but nothing - Michael Huisamen 18 Jan 2017 at 04:03 PM
Do you have the Bluetooth connected to anything else on your phone? - Marshall 19 Jan 2017 at 08:58 AM
No, only to the amp and the status is connected, the problem seems to start in the app - Michael Huisamen 21 Jan 2017 at 11:46 PM
Exact same issue here using Samsung S5. Tried my Galaxy Tab 4 but it says the Gateway app isn't compatible with it?? This is really poor. - steven Mckay 03 Feb 2017 at 03:00 PM
same issue with s7. The support from Marshall currently is very poor
- Stephen Henwood 25 Feb 2017 at 01:08 PM


Ok, I got it working, so here's the promised update:


1> Delete the app from the phone.

2> Open Settings on the phone, make sure bluetooth enabled, Amp is paired & connected. If not, stay there until fixed. (Mine did it fine, so...)

3> Keep phone within a foot or two of the amp. Reinstall app. When you first start it up it ought to go into a synch mode right away. Don't touch anything or mess with the app or phone until it completes an dall should be well. If you go to another app or otherwise do stuff on the phone the app may get confused and loose its lil mind, so just leave it be a minute - doesn't take long.

4> That did it for me. Happy pickin'!! :-D

answered 12 Jan 2017 at 06:46 PM

Steve Noyes (3)
You da man Steve! Finally, a solution that doesn't involve a bunch of horse manure. - Joe Phinney 26 Jan 2017 at 03:07 PM
Doesn't work for me. Newest firmware too. - steven Mckay 03 Feb 2017 at 03:02 PM


I made it work by disconnecting(forget) all bluetooth devices from phone and following Steve instructions.


edited 05 Jul 2019 at 10:54 PM

André Camillo (2)

answered 05 Jul 2019 at 10:50 PM

André Camillo (2)
As André said. An excellent comment. Thanks! - Gaston Khammar 04 Nov 2019 at 10:00 PM
This is what worked for me. Thank you guys so much this was driving me crazy. - Travis MacKerell 29 Jul 2020 at 05:13 PM



I havent been able to connect for months. THIS WORKS

it will reset all bluetooth, wifi, and network settings

Next Put the code in piring mode 

Next turn on bluetooth in your phone and pair the code

Next after its paired download app


Android 10 Galaxy S9 Plus

edited 11 May 2020 at 12:14 AM

Robert L (1)

answered 11 May 2020 at 12:11 AM

Robert L (1)


I had same problem like you before update firmware of CODE 25.
Update it :
And remove existing CODE connection of bluetooth settings in your device, then newly pair with it.
It will works.

answered 29 Dec 2016 at 03:50 AM

Seung-Won Lee (10)
I had to turn off both the phone (iphone 6s) and the amp, then restart phone first, then amp. then hold down REV & Power buttons on amp and to pairing in phone bluetooth settings on phone before launching gateway. This kinda worked until i tried to do too many changes while gettin texts from peeps and lost all the stuff i did. Maybe you'll have better luck. - John Reilly 29 Dec 2016 at 05:54 AM
I've updated the firmware and tried the other method and neither is working, any other suggestions? - Michael Huisamen 30 Dec 2016 at 01:25 PM


I'm having the same problem currently. Phone says it's paired just fine, but Gateway app doesn't find the amp even when phone is 1 foot away... :-(

If I find an answer I'll let you know.

answered 12 Jan 2017 at 12:24 AM

Steve Noyes (3)


Hi all,

Using the Galaxy S10 and Marshall Code 50, the solution for me was:

1) Unistall App Marshall Gateway;

2) Remove all Bluetooth devices from your connections;

3) Restart your Smartphone and the Amp Marshall Code;

4) Connect your smartphone to Bluetooth of Amp Marshall Code;

5) Install de App again ( Marshall Gateway);

6) Open and wait for some seconds... 

7) The red button to connect will appear.


Worked finally! Hours and hours spent to solve it.



Junio Vitor 

answered 27 Oct 2020 at 12:10 AM

Junio Vitor de Paula
Loading - please wait...